chocokanpan BLOG

2010 年 9 月 7 日

ThinkPad X100e で動画再生支援

Filed under: 未分類 — タグ: , — chocokanpan @ 10:30 AM

目的

第123回 ATI/AMDでも動画再生支援機能を使用する」を参考にして 動画再生支援を利用してみたいと思います。

材料

  • ThinkPad x100e (Ubuntu 10.04)
    • CPU:MV-40(i686)
    • 780G + Radeon HD 3200
      • ati-driver-installer-10-7-x86

インストール

第123回 ATI/AMDでも動画再生支援機能を使用する」に書いてある通り。ただ今回は、[システム]-[システム管理]-[ハードウェア・ドライバ]にある[ATI/AMD プロプライエタリ FGLRX グラフィックスドライバ]はインストールせず、事前にati-driver-installerをインストールしています。

  • 最新版のlibvaをビルド・インストール。
    • ただ、ビルド時にエラーが発生した。(dpkg-shlibdeps: error: no dependency information found for /usr/lib/libGL.so.1)ので

検索をした結果 libvaディレクトリ内にあるdebian/shlibs.localに以下のことを書いて、エラーを回避しました。

libGL 1 libgl1-mesa-glx | libgl1 | fglrx-glx
  • 最新版のxvba-videoを定位置に置く。
  • 最新版のmplayer-vaapiをビルド・インストール。

動画を見てみる

Big Buck Bunny をサンプル動画としてtopコマンドを用い、xorgとmplayerのCPU使用率を比べてみた。

vaapi Xorg mplayer
無効 11-15% 14-31%
有効 12-14% 9-10%

目視での数値だがだいたいこのぐらいたった。

比べてみるとmplayerの負荷が減っていることが分かる。

わーい 使える使える。

2010 年 3 月 4 日

ThinkPad x100e にUbuntuを再インストールした時のメモ

Filed under: 未分類 — タグ: , , — chocokanpan @ 2:30 PM

プロプラエタリなグラフィックドライバを無効せずATI Catalyst Display Driverを入れようとしたら画面が乱れてしまって、どうしようもならなかったので思い切って再インストールをしました。

その際のメモです。

  1. Ubuntu が起動した後、アップデートをかける。
  2. プロプラエタリなグラフィックドライバを有効にせずATI Catalyst Display Driverを入れる
  3. http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx?type=2.7&product=2.7.4.3.3.3.1&lang=English:ATI

  4. 無線LANのドライバを入れる(解凍してmake ,sudo -s,make install)
  5. どうやら10.04から無線LANドライバを入れる必要が無くなった様だ。

    https://help.ubuntu.com/community/WifiDocs/Device/Realtek%208172

  6. タッチパッドを無効にするなど自分の環境を構築する。

ATI Catalyst Display Driverを入れると、サスペンドが出来る他、マイクロフォンも使えるようになりました。

参考サイト:

X100eでUbuntu 9.10@64bit版を使う – ryunosinfxの日記

2010 年 2 月 15 日

ThinkPad x100e にUbuntuを入れてみた。

Filed under: 未分類 — タグ: , — chocokanpan @ 10:00 AM

ThinkPad x100e にUbuntu 9.10を入れてみました。

Ubuntuのインストールは、何も問題なく出来ました。

音と有線LAN、付属カメラも問題なく動きましたが、

無線LANとBluetoothの二つが初期のインストールで動きませんでした。

ただし、無線LANのみ対応策があったので試してみたところ、うまく動いたので記載します。

まず本体の中を見てみる。見てみると「Realtek RTL8191SE」だと分かったので

検索をしてみるとUbuntu Forumsにヒットしました。

Realtek RTL8191SE – Ubuntu Forums

http://ubuntuforums.org/showthread.php?t=1267961

上記のUbuntu Forums内にある。28番目のコメを参考に試してみるとうまく動きました。

http://ubuntuforums.org/showpost.php?p=8723901&postcount=28

Powered by WordPress